summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-14 15:47:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-15 00:12:11 +0100
commit2c560aa217284c3152378e5c79f0519d78cba226 (patch)
tree15b35e255499e17101df5e0ad044a32a85a45d2f /gnu/packages/web.scm
parent16144199c3689def649ec65a45766a7d5862e868 (diff)
gnu: perl-www-curl: Fix build with curl@7.69.1.
* gnu/packages/web.scm (perl-www-curl)[source]: Add perl-www-curl-fix-struct-void.patch. * gnu/packages/patches/perl-www-curl-remove-symbol.patch: Update. * gnu/packages/patches/perl-www-curl-fix-struct-void.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0bfaa3b9d7..8947889cd7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4423,14 +4423,14 @@ RFC 6570.")
(uri (string-append
"mirror://cpan/authors/id/S/SZ/SZBALINT/WWW-Curl-"
version".tar.gz"))
- (patches (search-patches "perl-www-curl-remove-symbol.patch"))
+ (patches (search-patches "perl-www-curl-fix-struct-void.patch"
+ "perl-www-curl-remove-symbol.patch"))
(sha256
(base32
"1fmp9aib1kaps9vhs4dwxn7b15kgnlz9f714bxvqsd1j1q8spzsj"))))
(build-system perl-build-system)
(arguments
'(#:tests? #f ;XXX: tests require network access
-
#:phases (modify-phases %standard-phases
(add-before 'configure 'set-search-path
(lambda _