summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-06-24 05:37:45 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-08-30 12:53:39 +0530
commita00379e7dcc4b0679acc8fb83336e03c79947fe1 (patch)
tree4fae26a985f96149e77ef8393820dfb1b8398aef /gnu/packages/web.scm
parentc93ffc11d05cbffe77e5b6abc82b4a9e0e73847f (diff)
gnu: Add linkchecker.
* gnu/packages/web.scm (linkchecker): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2ad1b6b7a7..0e0058b48b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5054,3 +5054,46 @@ websites lacking feeds. Supported websites include Facebook, Twitter,
Instagram and YouTube.")
(license (list l:public-domain
l:expat)))) ;; vendor/simplehtmldom/simple_html_dom.php
+
+(define-public linkchecker
+ (package
+ (name "linkchecker")
+ (version "9.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "LinkChecker" version))
+ (sha256
+ (base32
+ "0v8pavf0bx33xnz1kwflv0r7lxxwj7vg3syxhy2wzza0wh6sc2pf"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python2-requests" ,python2-requests)))
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ ;; Remove faulty python-requests version check. This has been fixed
+ ;; upstream, and can be removed in version 9.4.
+ (add-after 'unpack 'remove-python-requests-version
+ (lambda _
+ (substitute* "linkcheck/__init__.py"
+ (("requests.__version__ <= '2.2.0'") "False"))
+ #t)))))
+ (home-page "https://linkcheck.github.io/linkchecker")
+ (synopsis "Check websites for broken links")
+ (description "LinkChecker is a website validator. It checks for broken
+links in websites. It is recursive and multithreaded providing output in
+colored or normal text, HTML, SQL, CSV, XML or as a sitemap graph. It
+supports checking HTTP/1.1, HTTPS, FTP, mailto, news, nntp, telnet and local
+file links.")
+ (license (list l:gpl2+
+ l:bsd-2 ; linkcheck/better_exchook2.py
+ l:bsd-3 ; linkcheck/colorama.py
+ l:psfl ; linkcheck/gzip2.py
+ l:expat ; linkcheck/mem.py
+ ;; FIXME: Unbundle dnspython and miniboa
+ ;; This issue has been raised upstream
+ ;; https://github.com/wummel/linkchecker/issues/729
+ l:isc ; third_party/dnspython
+ l:asl2.0)))) ; third_party/miniboa