summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-11-06 03:29:06 -0500
committerMark H Weaver <mhw@netris.org>2016-11-06 03:29:06 -0500
commit8b6ad165d1fa479e5da2938d099dba356186e07c (patch)
treec30c024fd79497031c21c68d6c5688334d900467 /gnu/packages/web.scm
parent9422c98a0a2bf2c48d8e10e59d838ab23870eb10 (diff)
parent7f4658983a742072be4e28b227d6349461e9a68b (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8ef041a2fd..c6ad0b117f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3310,6 +3310,35 @@ various contexts including the R console, R Markdown documents, and Shiny web
applications.")
(license l:expat)))
+(define-public r-htmltable
+ (package
+ (name "r-htmltable")
+ (version "1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "htmlTable" version))
+ (sha256
+ (base32
+ "0x2f2hrbhvm53zqwn0ny9wxbk34nwf6zww8cx4bjy5ax15asdllm"))))
+ (properties `((upstream-name . "htmlTable")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-knitr" ,r-knitr)
+ ("r-magrittr" ,r-magrittr)
+ ("r-stringr" ,r-stringr)))
+ (home-page "http://gforge.se/packages/")
+ (synopsis "Advanced tables for Markdown/HTML")
+ (description
+ "This package provides functions to build tables with advanced layout
+elements such as row spanners, column spanners, table spanners, zebra
+striping, and more. While allowing advanced layout, the underlying
+CSS-structure is simple in order to maximize compatibility with word
+processors such as LibreOffice. The package also contains a few text
+formatting functions that help outputting text compatible with HTML or
+LaTeX.")
+ (license l:gpl3+)))
+
(define-public r-curl
(package
(name "r-curl")