summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-22 16:04:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-12-24 10:10:40 +0100
commita05996e00094caecd87fea4f59fb07cd9b2cc656 (patch)
tree65badee3a4a7348fb6bb41181240af96bf4587ed /gnu/packages/web.scm
parentb494a5f1bd63fe302cd20a0af01c3ad93fa42b9f (diff)
gnu: Add HTML::Template.
* gnu/packages/web.scm (perl-html-template): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e6659ec148..593fe3b857 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1894,6 +1894,30 @@ are invoked.")
kinds of HTML parsing operations.")
(home-page "http://search.cpan.org/dist/HTML-Tagset/")))
+(define-public perl-html-template
+ (package
+ (name "perl-html-template")
+ (version "2.95")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/W/WO/WONKO/"
+ "HTML-Template-" version ".tar.gz"))
+ (sha256
+ (base32
+ "07ahpfgidxsw2yb7y8i7bbr8s64aq6qgq832h9jswmksxbd0l43q"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/HTML-Template")
+ (synopsis "HTML-like templates")
+ (description
+ "This module attempts to make using HTML templates simple and natural.
+It extends standard HTML with a few new HTML-esque tags: @code{<TMPL_VAR>},
+@code{<TMPL_LOOP>}, @code{<TMPL_INCLUDE>}, @code{<TMPL_IF>},
+@code{<TMPL_ELSE>} and @code{<TMPL_UNLESS>}. The file written with HTML and
+these new tags is called a template. Using this module you fill in the values
+for the variables, loops and branches declared in the template. This allows
+you to separate design from the data.")
+ (license (package-license perl))))
+
(define-public perl-http-body
(package
(name "perl-http-body")