summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@cray.com>2018-08-29 14:12:58 -0500
committerEric Bavier <bavier@member.fsf.org>2018-08-30 00:44:40 -0500
commitf9e140a243b6d6b5d28bd0813b69604562a39653 (patch)
treec5384286bd993db9addb0077656a2012c56d0727 /gnu/packages/web.scm
parentc558113fb9ac60b8ec9ffca6f8059518514c548c (diff)
netsurf: Upgrade to 3.8.
* gnu/packages/patches/netsurf-message-timestamp.patch: New patch. * gnu/packages/patches/netsurf-system-utf8proc.patch: Adjust to new source. * gnu/packages/web.scm (netsurf): Upgrade to 3.8. [source]: Add the new patch.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6fc917b6be..0d27fa0054 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4694,7 +4694,7 @@ w3c webidl files and a binding configuration file.")
(define-public netsurf
(package
(name "netsurf")
- (version "3.7")
+ (version "3.8")
(source
(origin
(method url-fetch)
@@ -4702,10 +4702,11 @@ w3c webidl files and a binding configuration file.")
"releases/source/netsurf-" version "-src.tar.gz"))
(sha256
(base32
- "05kynfzzwd4fc03vbqdjpghh5xnk2yrh43w7vikak89vla30mhpg"))
+ "0hjm1h4m1i913y4mhkl7yqdifn8k70fwi58zdh6faypawzryc3m0"))
(patches (search-patches "netsurf-system-utf8proc.patch"
"netsurf-y2038-tests.patch"
- "netsurf-longer-test-timeout.patch"))))
+ "netsurf-longer-test-timeout.patch"
+ "netsurf-message-timestamp.patch"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("netsurf-buildsystem" ,netsurf-buildsystem)