summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorJames <james.taylor@fastmail.com>2023-03-19 13:31:09 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-02 22:28:54 +0200
commit5f9770e19d2d15698a8c637442e45a051cced76a (patch)
treeb45983e5750c550414684d722b108d776d7a210b /gnu/packages/web.scm
parentbaaea549043df87a364af100c1e8847519d3ccdc (diff)
gnu: Add nntpit.
* gnu/packages/web.scm (nntpit): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7b05a99752..90337b8dd8 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6510,6 +6510,32 @@ internetarchive python module for programmatic access to archive.org.")
snippets on @url{https://commandlinefu.com}.")
(license license:expat))))
+(define-public nntpit
+ (let ((commit "c0d654736460d174a680b2e06c3a81ce883fc09a")
+ (revision "0"))
+ (package
+ (name "nntpit")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/taviso/nntpit")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kkdh2qpkfw97hzw9jsxy5jzmhhv8261bj63mvr5c9qwlp6qs46g"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake glib pkg-config))
+ (inputs (list curl json-c libev))
+ (synopsis "Minimal reddit2nntp gateway server")
+ (description
+ "This is a simple reddit2nntp gateway server that lets you use a newsreader
+ to follow discussions on reddit. The intention is for you to run it locally,
+ tell your newsreader to connect to localhost, and subreddits will appear as newsgroups!")
+ (home-page "https://github.com/taviso/nntpit")
+ (license license:expat))))
+
(define-public rss-bridge
(package
(name "rss-bridge")