summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-11-21 18:11:10 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-11-21 18:11:30 -0500
commit8d2a5a36af4c36dfa08c7ee75d7a06ebb7a8225a (patch)
tree0e0f0cc9d5fa5a3c783451d12b10ebdb4c0aafe9 /gnu/packages/web.scm
parentd1b786fe629ae9a80f37f64fdf48b9d7c132cd11 (diff)
parent42be8fa560a7554ac35801b46c3a0a007fd742ce (diff)
Merge branch 'master' into mesa-updates
Change-Id: I94c6874e5fdf916e3eb911f1a7df610cd3275474
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7363925aac..f06f0d6abf 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -64,6 +64,7 @@
;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2023 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
+;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7910,6 +7911,35 @@ features include:
@end enumerate\n")
(license license:expat)))
+(define-public monsterid
+ (let ((commit "5597f177b473343ff5cad9a6e0e5b255312c6096")
+ (revision "0"))
+ (package
+ (name "monsterid")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/splitbrain/monsterID")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ixyrrcbw96plcdna2rx1pqwisqy9hnr57kvamgj13lzlv2whdb3"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("monsterid.php" "share/web/monsterid/")
+ ("parts/" "share/web/monsterid/parts/"
+ #:include-regexp ("\\.png$")))))
+ (home-page "https://www.splitbrain.org/projects/monsterid")
+ (synopsis "The original MonsterID implementation")
+ (description
+ "MonsterID is a method to generate a unique monster image based upon a
+certain identifier (IP address, email address, whatever). It can be
+used to automatically provide personal avatar images in blog comments
+or other community services.")
+ (license license:expat))))
+
(define-public cat-avatar-generator
(let ((commit "9360ea33f79d1dad3e43494b09878b5e3f6b41fa")
(revision "1"))