summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-09-10 16:54:52 +0100
committerMarius Bakke <marius@gnu.org>2020-10-10 23:39:17 +0200
commit26f6bd0403ed20c1d26eca9d4f28a0da519a56ac (patch)
treefc4c156ccce483298bf65702022ef58df47d2770 /gnu/packages/web.scm
parentd7fb4199c770c3bd7ce755b1160aa19e9164f148 (diff)
gnu: Add buku.
* gnu/packages/web.scm (buku): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 54e914e900..17c6778728 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7421,6 +7421,37 @@ update an existing mirrored site, and resume interrupted downloads.
HTTrack is fully configurable, and has an integrated help system.")
(license license:gpl3+)))
+(define-public buku
+ (package
+ (name "buku")
+ (version "4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "buku" version))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1g1xhdskfn72xaraqzz2v8dl2iza7bzfpn17z2wdrzkq3ih7yvgg"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;FIXME: many tests need network access
+ (inputs
+ `(("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-certifi" ,python-certifi)
+ ("python-cryptography" ,python-cryptography)
+ ("python-html5lib" ,python-html5lib)
+ ("python-urllib3" ,python-urllib3)))
+ (home-page "https://github.com/jarun/buku")
+ (synopsis "Bookmark manager")
+ (description
+ "buku is a powerful bookmark manager written in Python3 and SQLite3.
+@command{buku} can auto-import bookmarks from your browser and present them
+in an interactive command-line interface that lets you compose and update
+bookmarks directly. It can also present them in a web interface with
+@command{bukuserver}.")
+ (license license:gpl3+)))
+
(define-public anonip
(package
(name "anonip")