summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-10-11 13:13:08 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-10-11 13:18:00 +0300
commit2a7f4be8f3beaeb051bf1e1912d8e517b8af1407 (patch)
tree849a697ac50bce90438ce5594b6a661ca55ec461 /gnu/packages/web.scm
parent34d436a4082b5c5f23b00e13eb8e5a92d957d704 (diff)
gnu: nginx: Allow to pass configure-flags.
* gnu/packages/web.scm (nginx)[arguments]<configure>: Accept '#:configure-flags'.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm49
1 files changed, 25 insertions, 24 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 17c6778728..1699c92366 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -254,31 +254,32 @@ Interface} specification.")
#t))
(replace 'configure
;; The configure script is hand-written, not from GNU autotools.
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key configure-flags outputs #:allow-other-keys)
(let ((flags
- (list (string-append "--prefix=" (assoc-ref outputs "out"))
- "--with-http_ssl_module"
- "--with-http_v2_module"
- "--with-pcre-jit"
- "--with-debug"
- ;; Even when not cross-building, we pass the
- ;; --crossbuild option to avoid customizing for the
- ;; kernel version on the build machine.
- ,(let ((system "Linux") ; uname -s
- (release "3.2.0") ; uname -r
- ;; uname -m
- (machine (match (or (%current-target-system)
- (%current-system))
- ("x86_64-linux" "x86_64")
- ("i686-linux" "i686")
- ("mips64el-linux" "mips64")
- ;; Prevent errors when querying
- ;; this package on unsupported
- ;; platforms, e.g. when running
- ;; "guix package --search="
- (_ "UNSUPPORTED"))))
- (string-append "--crossbuild="
- system ":" release ":" machine)))))
+ (append (list (string-append "--prefix=" (assoc-ref outputs "out"))
+ "--with-http_ssl_module"
+ "--with-http_v2_module"
+ "--with-pcre-jit"
+ "--with-debug"
+ ;; Even when not cross-building, we pass the
+ ;; --crossbuild option to avoid customizing for the
+ ;; kernel version on the build machine.
+ ,(let ((system "Linux") ; uname -s
+ (release "3.2.0") ; uname -r
+ ;; uname -m
+ (machine (match (or (%current-target-system)
+ (%current-system))
+ ("x86_64-linux" "x86_64")
+ ("i686-linux" "i686")
+ ("mips64el-linux" "mips64")
+ ;; Prevent errors when querying
+ ;; this package on unsupported
+ ;; platforms, e.g. when running
+ ;; "guix package --search="
+ (_ "UNSUPPORTED"))))
+ (string-append "--crossbuild="
+ system ":" release ":" machine)))
+ configure-flags)))
(setenv "CC" "gcc")
(format #t "configure flags: ~s~%" flags)
(apply invoke "./configure" flags)