summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-02-24 16:33:18 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-02-24 16:36:12 +0100
commitb5586c666e13988ce7ec983907ffb06a564f1d4f (patch)
treec08e925a93b328ec11170f826fd1f48ce0dc3abe /gnu/packages/web.scm
parent376329526be6660852ce8a3517c95607b3191ecb (diff)
gnu: http-server: Fix build on i686-linux.
* gnu/packages/patches/http-parser-fix-assertion-on-armhf.patch: Remove it. * gnu/local.mk (dist_patch_DATA): Update it. * gnu/packages/web.scm (http-parser)[source]: Remove a test assertion failing on i686-linux. [arguments]: Remove the "assertion.patch" that is merged upstream. [native-inputs]: Ditto. [synopsis]: Wrap it.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm30
1 files changed, 11 insertions, 19 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b3c0831ac4..e9a17f3b78 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6191,7 +6191,15 @@ into your tests. It automatically starts up a HTTP server in a separate thread
"f/0001-url-treat-empty-port-as-default.patch"))
(sha256
(base32
- "0pbxf2nq9pcn299k2b2ls8ldghaqln9glnp79gi57mamx4iy0f6g"))))))))
+ "0pbxf2nq9pcn299k2b2ls8ldghaqln9glnp79gi57mamx4iy0f6g"))))))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; This assertion fails when building for i686-linux.
+ (substitute* "test.c"
+ (("assert\\(sizeof\\(http_parser\\) == 32\\);")
+ "assert(1);"))
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -6204,14 +6212,6 @@ into your tests. It automatically starts up a HTTP server in a separate thread
'("CC=gcc")))
#:phases
(modify-phases %standard-phases
- ,@(match (%current-system)
- ("armhf-linux"
- '((add-before 'check 'apply-assertion.patch
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((patch (assoc-ref inputs "assertion.patch")))
- (invoke "patch" "-p1" "-i" patch)
- #t)))))
- (_ '()))
,@(if (%current-target-system)
'((replace 'configure
(lambda* (#:key target #:allow-other-keys)
@@ -6222,17 +6222,9 @@ into your tests. It automatically starts up a HTTP server in a separate thread
(string-append "AR=" target "-ar\n")))
#t)))
'((delete 'configure))))))
- (native-inputs
- `(,@(match (%current-system)
- ("armhf-linux"
- ;; A fix for <https://issues.guix.gnu.org/40604> which in turn
- ;; breaks i686-linux builds.
- `(("assertion.patch"
- ,@(search-patches "http-parser-fix-assertion-on-armhf.patch"))))
- (_ '()))))
(synopsis "HTTP request/response parser for C")
- (description "This is a parser for HTTP messages written in C. It parses
-both requests and responses. The parser is designed to be used in
+ (description "This is a parser for HTTP messages written in C. It
+parses both requests and responses. The parser is designed to be used in
high-performance HTTP applications. It does not make any syscalls nor
allocations, it does not buffer data, it can be interrupted at anytime.
Depending on your architecture, it only requires about 40 bytes of data per