summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-04-22 22:31:56 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-22 22:31:56 +0200
commit0a164b344d6dabb0dc38f61cc2f4868fa15dec63 (patch)
tree831ca040983e32fe266732f63b323053355ce615 /gnu/packages/web.scm
parentdcf2de77e195c7bce14006f69762396550d3630e (diff)
parent5b545763ed9b8a3fade7f756d543819fc090953f (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm62
1 files changed, 54 insertions, 8 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f17f47f1e0..7027fbad08 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
;;; Copyright © 2014-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015-2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Raoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Eric Bavier <bavier@posteo.net>
@@ -1528,22 +1528,34 @@ for efficient socket-like bidirectional reliable communication channels.")
(define-public wabt
(package
(name "wabt")
- (version "1.0.12")
+ (version "1.0.32")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/WebAssembly/wabt")
- (commit version)))
+ (commit version)
+ (recursive? #true)))
(file-name (git-file-name name version))
(sha256
- (base32 "1zlv3740wkqj4mn6sr84h0x6wk2lcp4pwwmqsh5yyqp1j1glbsa0"))))
+ (base32 "0m124r8v9c0hxiaa4iy7ch4ng8msnirbc2vb702gbdjhvgzyrcwh"))
+ (modules '((guix build utils)))
+ (snippet
+ '(delete-file-recursively "third_party/gtest/"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DBUILD_TESTS=OFF")
- #:tests? #f))
- (inputs `(("python" ,python-2)
- ("re2c" ,re2c)))
+ (list
+ #:test-target "run-tests"
+ #:configure-flags '(list "-DUSE_SYSTEM_GTEST=ON")
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'use-gcc
+ (lambda _ (setenv "CC" "gcc")))
+ ;; XXX This is the only test that fails.
+ (add-after 'unpack 'delete-broken-test
+ (lambda _
+ (delete-file "test/wasm2c/spec/memory_init.txt"))))))
+ (native-inputs (list python googletest))
(home-page "https://github.com/WebAssembly/wabt")
(synopsis "WebAssembly Binary Toolkit")
(description "WABT (pronounced: wabbit) is a suite of tools for
@@ -7977,6 +7989,40 @@ update an existing mirrored site, and resume interrupted downloads.
HTTrack is fully configurable, and has an integrated help system.")
(license license:gpl3+)))
+(define-public binaryen
+ (package
+ (name "binaryen")
+ (version "112")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/WebAssembly/binaryen")
+ (commit (string-append "version_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0970iz22yjxgi27d67kwmrx4zq7hig3i6b92vmlp4c4bd1bacny5"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'use-system-googletest
+ (lambda _
+ (substitute* "third_party/CMakeLists.txt"
+ ((" googletest/.*") "")
+ (("add_library\\(gtest.*") ""))
+ (substitute* "CMakeLists.txt"
+ (("add_subdirectory\\(test/gtest\\)")
+ "find_package(GTest REQUIRED)")))))))
+ (native-inputs (list googletest))
+ (home-page "https://github.com/WebAssembly/binaryen")
+ (synopsis "Optimizer and compiler/toolchain library for WebAssembly")
+ (description "Binaryen is a compiler and toolchain infrastructure library
+for WebAssembly, written in C++. It aims to make compiling to WebAssembly
+easy, fast, and effective.")
+ (license license:asl2.0)))
+
(define-public buku
(package
(name "buku")