summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorKarl Hallsby <karl@hallsby.com>2023-04-20 23:39:31 -0500
committerLeo Famulari <leo@famulari.name>2023-04-23 11:31:47 -0400
commit44905f2795a83a4e4f7d80700497c09f2e9fef3a (patch)
treea0034229ac524e0393e933bbf018dc7c7676b7a6 /gnu/packages/webkit.scm
parent3575af7bdc44c5563bb0af05cdd1268d1c682e13 (diff)
gnu: webkitgtk: Update to 2.40.1 [security fixes].
Fixes CVE-2022-0108, CVE-2022-32885, CVE-2023-27932, CVE-2023-27954, and CVE-2023-28205. * gnu/packages/webkit.scm: Update to 2.40.1. [source]: Remove obsolete patch. * gnu/packages/patches/webkitgtk-libelogind.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index e5eafcb142..5b2bac7b15 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -127,16 +127,15 @@ engine that uses Wayland for graphics output.")
(define-public webkitgtk
(package
(name "webkitgtk") ; webkit2gtk4
- (version "2.40.0")
+ (version "2.40.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.webkitgtk.org/releases/"
name "-" version ".tar.xz"))
(sha256
- (base32 "14xkgamqlshxqw6fcslvw0yzj4y5mvx66b6bn64rwrl9pyhpwq54"))
+ (base32 "1xky3cy4l5k0nj366pk17lrzy0n0k6plks9sy0g1dllc9yc2drb4"))
(patches (search-patches
- "webkitgtk-adjust-bubblewrap-paths.patch"
- "webkitgtk-libelogind.patch"))))
+ "webkitgtk-adjust-bubblewrap-paths.patch"))))
(build-system cmake-build-system)
(outputs '("out" "doc" "debug"))
(arguments