summaryrefslogtreecommitdiff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-29 13:18:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-29 16:12:47 +0200
commit07cda02c5b6bc44007c1d3f44b7f003b35ac07ec (patch)
treec9b61d3730b9c253635d39820c0cee5b142c3339 /gnu/packages/wine.scm
parent658c987fdd30c9cc071fd819c7e6d27bdb02600e (diff)
gnu: wine: Use 'modify-phases' syntax.
* gnu/packages/wine.scm (wine)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index d2d3fdd80b..367f27af5e 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -118,18 +118,18 @@
(list "SHELL=bash")
#:phases
- (alist-cons-after
- 'configure 'patch-dlopen-paths
- ;; Hardcode dlopened sonames to absolute paths.
- (lambda _
- (let* ((library-path (search-path-as-string->list
- (getenv "LIBRARY_PATH")))
- (find-so (lambda (soname)
- (search-path library-path soname))))
- (substitute* "include/config.h"
- (("(#define SONAME_.* )\"(.*)\"" _ defso soname)
- (format #f "~a\"~a\"" defso (find-so soname))))))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-after 'configure 'patch-dlopen-paths
+ ;; Hardcode dlopened sonames to absolute paths.
+ (lambda _
+ (let* ((library-path (search-path-as-string->list
+ (getenv "LIBRARY_PATH")))
+ (find-so (lambda (soname)
+ (search-path library-path soname))))
+ (substitute* "include/config.h"
+ (("(#define SONAME_.* )\"(.*)\"" _ defso soname)
+ (format #f "~a\"~a\"" defso (find-so soname))))
+ #t))))))
(home-page "https://www.winehq.org/")
(synopsis "Implementation of the Windows API")
(description