summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2022-10-20 09:25:13 -0300
committerLudovic Courtès <ludo@gnu.org>2022-12-04 23:08:20 +0100
commit8eb0abf32f506195f45eeb49f91516705c39ad13 (patch)
tree42ddd4b1c10c4b7ebd0e34703f06d223be15b9dc /gnu/packages/wm.scm
parent2e75b328b6bbdadbffe5b643a4891b5026a0defd (diff)
gnu: Add velox.
* gnu/packages/wm.scm (velox): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 149ea1bb69..04a44b4c15 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -3033,3 +3033,35 @@ notable features include:
@item Can place borders around windows
@end itemize")
(license license:expat))))
+
+(define-public velox
+ (let ((commit "fcc041265539befd907a64ee3a536cb2489ffb99")
+ (revision "1"))
+ (package
+ (name "velox")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/michaelforney/velox")
+ (commit commit)))
+ (sha256
+ (base32
+ "0d11bmag5zwmas3rf1b7x5hjla7wpxq70nr86dz3x9r7cal04mym"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:make-flags (list (string-append "CC="
+ ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs (list libinput libxkbcommon wayland wld))
+ (propagated-inputs (list swc))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/michaelforney/velox")
+ (synopsis "Simple window manager based on swc")
+ (description "velox is a simple window manager for Wayland based on swc.
+It is inspired by dwm and xmonad.")
+ (license license:expat))))