summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-15 13:06:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-16 07:45:07 +0300
commit9315b3fbffa845120a2f5f61f38820ddae8e449f (patch)
tree3ef8ecaaafd0d87c8eea14a737399da2f8f086c5 /gnu/packages/wm.scm
parent5cf8b0a46e2597ee8e4558e9be6c7af2cfcc0680 (diff)
gnu: wlroots: Fix cross-compiling.
* gnu/packages/wm.scm (wlroots)[arguments]: Adjust custom phases to also search for files from native-inputs. [native-inputs]: Add wayland. When cross-compiling add pkg-config-for-build.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 4950b7fa38..ba7bd9d316 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1643,10 +1643,10 @@ functionality to display information about the most commonly used services.")
"/bin/Xwayland")))
#t))
(add-before 'configure 'fix-meson-file
- (lambda* (#:key inputs #:allow-other-keys)
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
(substitute* "backend/drm/meson.build"
(("/usr/share/hwdata/pnp.ids")
- (string-append (assoc-ref inputs "hwdata")
+ (string-append (assoc-ref (or native-inputs inputs) "hwdata")
"/share/hwdata/pnp.ids"))))))))
(propagated-inputs
(list ;; As required by wlroots.pc.
@@ -1662,9 +1662,13 @@ functionality to display information about the most commonly used services.")
xcb-util-wm
xorg-server-xwayland))
(native-inputs
- (list
+ (cons*
`(,hwdata "pnp")
- pkg-config))
+ pkg-config
+ wayland
+ (if (%current-target-system)
+ (list pkg-config-for-build)
+ '())))
(home-page "https://gitlab.freedesktop.org/wlroots/wlroots/")
(synopsis "Pluggable, composable, unopinionated modules for building a
Wayland compositor")