summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-09-27 02:06:30 -0400
committer宋文武 <iyzsong@member.fsf.org>2022-09-28 10:36:59 +0800
commita5ae3d781bc67000b09bd1a17be7d7110bd29eb2 (patch)
tree88957de58792ee089c1741b026dde110c49239fe /gnu/packages/wm.scm
parent12fd8b5280ea1cfe442abb7b7284f85e03ae2f9d (diff)
gnu: swaylock-effects: Update to 1.6.10, use G-expressions.
* gnu/packages/wm.scm (swaylock-effects): Update to 1.6.10. [source]: Switch from commit to release tag. [arguments]: Use G-expressions. [home-page]: Switch to maintained fork. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm47
1 files changed, 19 insertions, 28 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 310e62a00d..5699e42540 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1675,36 +1675,27 @@ modules for building a Wayland compositor.")
(license license:expat))) ; MIT license
(define-public swaylock-effects
- ;; Latest release is from November 2020, but doesn't support disabling SSE.
- (let ((commit "5cb9579faaf5662b111f5722311b701eff1c1d00")
- (revision "1"))
- (package
- (inherit swaylock)
- (name "swaylock-effects")
- (version (git-version "1.6-3" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mortie/swaylock-effects")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "036dkhfqgk7g9vbr5pxgrs66h5fz0rwdsc67i1w51aa9v01r35ca"))))
- (arguments
- `(#:configure-flags '("-Dsse=false")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-meson
- (lambda _
- (substitute* "meson.build"
- (("'-mtune=native',") "")))))))
- (synopsis "Screen locking utility for Wayland compositors with effects")
- (description "@code{Swaylock-effects} is a fork of swaylock with additional
+ (package
+ (inherit swaylock)
+ (name "swaylock-effects")
+ (version "1.6.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jirutka/swaylock-effects")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d8ri7bzwfr53ybgf23acz57wyhcl2f1nqprcda1v9bzfgsqfk2n"))))
+ (arguments
+ (list #:configure-flags #~'("-Dsse=false")))
+ (synopsis "Screen locking utility for Wayland compositors with effects")
+ (description "@code{Swaylock-effects} is a fork of swaylock with additional
features, such as the ability to take a screenshot as the background image,
display a clock or apply image manipulation techniques to the background image.")
- (home-page "https://github.com/mortie/swaylock-effects"))))
+ (home-page "https://github.com/jirutka/swaylock-effects")))
(define-public swaybg
(package