summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-02-28 11:02:06 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-03-01 09:47:26 +0800
commitf926fd50d1374b9a09f0855239a7bdede332cd9c (patch)
tree293295c55886d9ad43c5ebe6db9f1fab4f44d1da /gnu/packages/wm.scm
parent1c1d7e3db95d0250aba7b5a90ce22742f5070071 (diff)
gnu: herbstluftwm: Enable Xcursor support.
* gnu/packages/wm.scm (herbstluftwm)[inputs]: Add libxcursor. [arguments]: Set 'LDFLAGS' to '-lXcursor'.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 55838314db..c656101159 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -208,6 +208,7 @@ the leaves of a full binary tree.")
xterm
xsetroot
libx11
+ libxcursor
libxext
libxfixes
libxinerama
@@ -224,6 +225,10 @@ the leaves of a full binary tree.")
(string-append "-DBASHCOMPLETIONDIR=" out "/etc/bash_completion.d")))
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'link-libxcursor
+ (lambda _
+ ;; libX11 will dlopen libXcursor to load cursors.
+ (setenv "LDFLAGS" "-lXcursor")))
(add-after 'install 'install-xsession
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))