summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-10-06 22:43:18 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-10-06 22:56:20 +0300
commit2aa393326d904e9bfa9f460c14d553b2b37f347c (patch)
treee71d0890ae4e0297281c63d32c5da9ab5c94bec9 /gnu/packages/wm.scm
parent38094a4f8d56ea8f3ce200a88a2a11885c929348 (diff)
gnu: Add xnotify.
* gnu/packages/wm.scm (xnotify): New variable.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 40458f55ab..2c877038b1 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2044,3 +2044,39 @@ execute a shell command on a configurable action. The icons can be moved on
the desktop by dragging them, and the icons will remember their positions on
start-up.")
(license license:bsd-3)))
+
+(define-public xnotify
+ (package
+ (name "xnotify")
+ (version "0.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phillbush/xnotify")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ris7jhi7hgw7nxkwkn3zk7n3y4nvnnm6dbz0qs0g2srp2k67v7v"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxft" ,libxft)
+ ("libxinerama" ,libxinerama)
+ ("imlib2" ,imlib2)))
+ (arguments
+ `(#:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output)
+ (string-append "CFLAGS="
+ "-I" (assoc-ref %build-inputs "freetype")
+ "/include/freetype2"))
+ #:tests? #f ;no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/phillbush/xnotify")
+ (synopsis "Displays a notification on the screen")
+ (description "XNotify receives a notification specification in stdin and
+shows a notification for the user on the screen.")
+ (license license:expat)))