summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-10-13 23:39:27 +0200
committerMarius Bakke <marius@gnu.org>2020-10-13 23:39:27 +0200
commitf7175626ffce578be1bc6df4916a129f86557872 (patch)
tree2eb0040522f2883764b3e09dc36595d68eeb14c1 /gnu/packages/wm.scm
parent2b6ecdf41a09ab9ecae06d7c537583a2f0f28efc (diff)
parente8c5533d26b4441c96e9ae92350efcb24d787c4b (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm51
1 files changed, 45 insertions, 6 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c379f70b21..2fafee29a0 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1597,7 +1597,11 @@ compositors that support the layer-shell protocol.")
(base32 "1ha8803ll7472kqxsy2xz0v5d4sv8apmc9z631d67m31q0z1m9rz"))))
(build-system asdf-build-system/sbcl)
(native-inputs `(("fiasco" ,sbcl-fiasco)
- ("texinfo" ,texinfo)))
+ ("texinfo" ,texinfo)
+
+ ;; To build the manual.
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)))
(inputs `(("cl-ppcre" ,sbcl-cl-ppcre)
("clx" ,sbcl-clx)
("alexandria" ,sbcl-alexandria)))
@@ -1631,13 +1635,12 @@ compositors that support the layer-shell protocol.")
out)))
#t)))
(add-after 'install 'install-manual
- (lambda* (#:key outputs #:allow-other-keys)
- ;; The proper way to the manual is bootstrapping a full autotools
- ;; build system and running ‘./configure && make stumpwm.info’ to
- ;; do some macro substitution. We can get away with much less.
+ (lambda* (#:key (make-flags '()) outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(info (string-append out "/share/info")))
- (invoke "makeinfo" "stumpwm.texi.in")
+ (invoke "./autogen.sh")
+ (invoke "sh" "./configure" "SHELL=sh")
+ (apply invoke "make" "stumpwm.info" make-flags)
(install-file "stumpwm.info" info)
#t))))))
(synopsis "Window manager written in Common Lisp")
@@ -2039,3 +2042,39 @@ execute a shell command on a configurable action. The icons can be moved on
the desktop by dragging them, and the icons will remember their positions on
start-up.")
(license license:bsd-3)))
+
+(define-public xnotify
+ (package
+ (name "xnotify")
+ (version "0.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phillbush/xnotify")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ris7jhi7hgw7nxkwkn3zk7n3y4nvnnm6dbz0qs0g2srp2k67v7v"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxft" ,libxft)
+ ("libxinerama" ,libxinerama)
+ ("imlib2" ,imlib2)))
+ (arguments
+ `(#:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output)
+ (string-append "CFLAGS="
+ "-I" (assoc-ref %build-inputs "freetype")
+ "/include/freetype2"))
+ #:tests? #f ;no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/phillbush/xnotify")
+ (synopsis "Displays a notification on the screen")
+ (description "XNotify receives a notification specification in stdin and
+shows a notification for the user on the screen.")
+ (license license:expat)))