summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-16 20:56:38 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-16 20:56:38 +0200
commitdf570bf271536399993b39e7ea2ea0452bb6cde4 (patch)
tree32cde458f90c599691831fc33cfbd4efcca9e9eb /gnu/packages/wm.scm
parent37d203985e2817b0962129384e8b993a1bb92de9 (diff)
parent5f9a9945b5747e5ec284f8b116b2e8cc1b9064d7 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index e83f07bc54..cad1cba4ce 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -248,7 +248,7 @@ developers.")
(propagated-inputs
`(("perl-anyevent" ,perl-anyevent)
("perl-json-xs" ,perl-json-xs)))
- (home-page "http://search.cpan.org/dist/AnyEvent-I3")
+ (home-page "https://metacpan.org/release/AnyEvent-I3")
(synopsis
"Communicate with the i3 window manager through perl")
(description
@@ -505,14 +505,14 @@ tiled on several screens.")
(define-public xmobar
(package
(name "xmobar")
- (version "0.26")
+ (version "0.27")
(source (origin
(method url-fetch)
(uri (string-append "mirror://hackage/package/xmobar/"
name "-" version ".tar.gz"))
(sha256
(base32
- "19g40vqj3cs94i27f66194k7d5cazrv1lx54bz9kc0qy2npxjzgz"))))
+ "0agx490q6sbmv3vfq33ys8dsrgwizj3bmha4i1pkxz5wp5q8cx3l"))))
(build-system haskell-build-system)
(native-inputs
`(("ghc-hspec" ,ghc-hspec)
@@ -522,6 +522,7 @@ tiled on several screens.")
("ghc-http" ,ghc-http)
("ghc-iwlib" ,ghc-iwlib)
("ghc-parsec" ,ghc-parsec)
+ ("ghc-parsec-numbers" ,ghc-parsec-numbers)
("ghc-regex-compat" ,ghc-regex-compat)
("ghc-stm" ,ghc-stm)
("ghc-x11-xft" ,ghc-x11-xft)