summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-15 13:06:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-15 13:06:53 +0300
commit76b706c71ce1e1c2a140856a80cdd60bd8d4b0fd (patch)
tree613e1024267e51405f64057af1fcecaad47ea940 /gnu/packages/wm.scm
parentdc2cfc9bea6f79095fdf363362823c0eabb95022 (diff)
gnu: wlroots: Fix cross-compiling.
* gnu/packages/wm.scm (wlroots)[arguments]: Adjust custom phases to also search for files from native-inputs. [native-inputs]: Add wayland. When cross-compiling add pkg-config-for-build.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index af429916bf..cdc8b57030 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1644,10 +1644,10 @@ functionality to display information about the most commonly used services.")
"/bin/Xwayland")))
#t))
(add-before 'configure 'fix-meson-file
- (lambda* (#:key inputs #:allow-other-keys)
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
(substitute* "backend/drm/meson.build"
(("/usr/share/hwdata/pnp.ids")
- (string-append (assoc-ref inputs "hwdata")
+ (string-append (assoc-ref (or native-inputs inputs) "hwdata")
"/share/hwdata/pnp.ids"))))))))
(propagated-inputs
(list ;; As required by wlroots.pc.
@@ -1663,9 +1663,13 @@ functionality to display information about the most commonly used services.")
xcb-util-wm
xorg-server-xwayland))
(native-inputs
- (list
+ (cons*
`(,hwdata "pnp")
- pkg-config))
+ pkg-config
+ wayland
+ (if (%current-target-system)
+ (list pkg-config-for-build)
+ '())))
(home-page "https://gitlab.freedesktop.org/wlroots/wlroots/")
(synopsis "Pluggable, composable, unopinionated modules for building a
Wayland compositor")