summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2023-05-10 10:38:48 +0800
committerLudovic Courtès <ludo@gnu.org>2023-05-21 01:15:48 +0200
commit7ddc239fc38c2a0d73c997ecff80d6fdd9a594c7 (patch)
treed26d0f9449bd35ffa9d9e3658657597ea576a0f1 /gnu/packages/wm.scm
parent9f5f9ebc92aa197301eff1808733e968813c0a2d (diff)
gnu: Add labwc.
* gnu/packages/wm.scm (labwc): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index e760ff4aa2..4360f3722b 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -112,6 +112,7 @@
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gperf)
@@ -2806,6 +2807,47 @@ for wayland conceptually based on the X11 window manager
read and write, and compatible with JSON.")
(license license:bsd-2)))
+(define-public labwc
+ (package
+ (name "labwc")
+ (version "0.6.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/labwc/labwc")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zbgj8r8ppvqnz2imh6f825f2lvsqpiqfa0r5g5r4nsvadiipivp"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list pkg-config gettext-minimal scdoc))
+ (inputs
+ (list cairo
+ glib
+ libxcb
+ libxml2
+ pango
+ wlroots))
+ (home-page "https://labwc.github.io")
+ (synopsis "Window-stacking compositor for Wayland")
+ (description
+ "Labwc is lightweight and independent with a focus on simply stacking
+windows well and rendering some window decorations, it is inspired by Openbox.
+It takes a no-bling/frills approach and says no to features such as icons
+(except window buttons), animations, decorative gradients and any other
+options not required to reasonably render common themes. It relies on clients
+for panels, screenshots, wallpapers and so on to create a full desktop
+environment.
+
+Labwc tries to stay in keeping with wlroots and sway in terms of general
+approach and coding style.
+
+Labwc has no reliance on any particular Desktop Environment, Desktop Shell or
+session. Nor does it depend on any UI toolkits such as Qt or GTK.")
+ (license license:gpl2)))
+
(define-public hikari
(package
(name "hikari")