summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2023-03-12 19:52:54 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-15 15:49:20 +0100
commit8a479494633395f5a4a088e2c52380bcb22f4fe8 (patch)
treea5f9b04e3fa0ddfd96bcd3835e6fdd43c15f521f /gnu/packages/wm.scm
parent2c58713241b12e0302fb84b20432d11c4bc5790e (diff)
gnu: Add sbcl-stumpwm-hostname.
* gnu/packages/wm.scm (sbcl-stumpwm-hostname): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 92fd740b40..b55525b580 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -46,7 +46,7 @@
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
-;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021, 2023 jgart <jgart@dismail.de>
;;; Copyright © 2021 Disseminate Dissent <disseminatedissent@protonmail.com>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Gabriel Wicki <gabriel@erlikon.ch>
@@ -2377,6 +2377,25 @@ one in Emacs.")
PNG files.")
(license license:gpl3+)))
+(define-public sbcl-stumpwm-hostname
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-hostname")
+ (arguments
+ '(#:asd-systems '("hostname")
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "modeline/hostname"))))))
+ (home-page
+ "https://github.com/stumpwm/stumpwm-contrib/tree/master/modeline/hostname")
+ (synopsis "Put hostname in the StumpWM modeline")
+ (description "This StumpWM module puts the hostname in the StumpWM
+modeline.")
+ (license license:gpl3+)))
+
(define-public sbcl-stumpwm-notify
(package
(inherit stumpwm-contrib)