summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-01-04 09:37:26 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-02-26 10:20:11 +0100
commitcad6aa8082e99fe60570e3fd53a0e5876a8f243e (patch)
tree2704c2060dfdd956dfe2a455673aa7ac9e923395 /gnu/packages/wm.scm
parent84549dcf380b1ed7712816a1ff1bfe9688c1d9a7 (diff)
gnu: Add upstream-name property to Haskell packages.
Script-aided bulk change.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index e8bf3f6ac9..0dfc45a58e 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -816,6 +816,7 @@ manager and a system tray.")
"04qspdz9w6xpw1npcmx2zx0595wc68q985pv4i0hvp32zillvdqy"))
(patches (search-patches "xmonad-next-dynamic-linking.patch"))))
(build-system haskell-build-system)
+ (properties '((upstream-name . "xmonad")))
(inputs (list ghc-data-default-class ghc-setlocale ghc-x11))
(native-inputs (list ghc-quickcheck ghc-quickcheck-classes))
(arguments
@@ -885,6 +886,7 @@ tiled on several screens.")
(base32
"0gdphjn5ll5lkb2psdsb34563wsz6g0y2gg3z8cj4jy8lvbbv808"))))
(build-system haskell-build-system)
+ (properties '((upstream-name . "xmobar")))
(native-inputs
(list ghc-hspec hspec-discover))
(inputs
@@ -958,6 +960,7 @@ particular, it displays commonly-chosen options before uncommon ones.")
(sha256
(base32 "11g1cyfgfvcmz35qhgi9wzxrk3br8m8b7qy3jvph4nnf6aj13wvy"))))
(build-system haskell-build-system)
+ (properties '((upstream-name . "xmonad-contrib")))
(propagated-inputs (list ghc-random ghc-x11 ghc-utf8-string ghc-x11-xft xmonad-next))
(native-inputs (list ghc-quickcheck ghc-hspec))
(home-page "https://xmonad.org")