summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorSughosha via Guix-patches via <guix-patches@gnu.org>2023-01-27 16:44:38 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-18 12:36:10 +0100
commit39c50eb49540bbc90b20152520be4fd095d5f979 (patch)
treea2600d63c5396a6eb19566a25f7c490f89a83bc3 /gnu/packages/xdisorg.scm
parent58cb4e28d30a06f831e047909314cb5820372bda (diff)
gnu: Add nwg-launchers.
* gnu/packages/xdisorg.scm (nwg-launchers): New variable. Co-authored-by: florhizome <florhizome@posteo.net> Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index a92456f9e4..ddb70bd817 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -98,6 +98,7 @@
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
@@ -3099,6 +3100,29 @@ such as sway, similar to @command{rofi}.")
(home-page "https://hg.sr.ht/~scoopta/wofi")
(license license:gpl3+)))
+(define-public nwg-launchers
+ (package
+ (name "nwg-launchers")
+ (version "0.7.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nwg-piotr/nwg-launchers")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hq2qiqxvrw3g515ywcb676ljc8mdw3pyslgxr3vahizfljah1pv"))))
+ (build-system meson-build-system)
+ (native-inputs (list json-modern-cxx pkg-config))
+ (inputs (list gtk-layer-shell gtkmm-3 librsvg))
+ (home-page "https://github.com/nwg-piotr/nwg-launchers")
+ (synopsis "Application launchers for wlroots")
+ (description
+ "This package provides an application grid, button bar, and dmenu
+applications for Sway and other wlroots-based Wayland compositors.")
+ (license license:gpl3+)))
+
(define-public dex
(package
(name "dex")