summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-09-30 03:10:50 -0400
committerLudovic Courtès <ludo@gnu.org>2022-10-15 00:44:09 +0200
commit8fbbb8fc317161299898751c79dd6b52818d4e6d (patch)
treea5c1d2326ca85b9a799341bd8fa791e2beecc0ae /gnu/packages/xdisorg.scm
parent807c0658c838e7380c5dfec05202f6dd4a29ab21 (diff)
gnu: bemenu: Update to 0.6.10, use new package style.
* gnu/packages/xdisorg.scm (bemenu): Update to 0.6.10. [arguments]: Use G-expressions. Use #$output instead of assoc-ref. [inputs]: Remove labels. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm39
1 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 09f13a33d7..7307360d6a 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -313,7 +313,7 @@ used to further tweak the behaviour of the different profiles.")
(define-public bemenu
(package
(name "bemenu")
- (version "0.6.4")
+ (version "0.6.10")
(source
(origin
(method git-fetch)
@@ -322,27 +322,28 @@ used to further tweak the behaviour of the different profiles.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "18vplvnymgc6576sdh84lm5rlwyb9d038plqpjs638hzskf4q577"))))
+ (base32 "0i2pv3qnb0l2ryvj9ycf9d5rng6yfk0kpjkq8hy6g956672wdzx6"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f
- #:make-flags (list ,(string-append "CC=" (cc-for-target))
- "CFLAGS=-O2 -fPIC"
- (string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib")
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
+ (list
+ #:tests? #f
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ "CFLAGS=-O2 -fPIC"
+ (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib")
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
(inputs
- `(("cairo" ,cairo)
- ("libx11" ,libx11)
- ("libxkbcomon" ,libxkbcommon)
- ("libxinerama" ,libxinerama)
- ("ncurses" ,ncurses)
- ("pango" ,pango)
- ("wayland" ,wayland)
- ("wayland-protocols" ,wayland-protocols)))
+ (list cairo
+ libx11
+ libxkbcommon
+ libxinerama
+ ncurses
+ pango
+ wayland
+ wayland-protocols))
(native-inputs
(list doxygen pkg-config))
(home-page "https://github.com/Cloudef/bemenu")