summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-12-08 12:12:28 +0100
committerLudovic Courtès <ludo@gnu.org>2022-12-08 13:07:45 +0100
commit901a424586240bd04b50613f4b5d34f8e25bbe87 (patch)
tree1e654ab8a5a31a4d35e724db51c517f55b8ed880 /gnu/packages/xdisorg.scm
parentc370998f0161c37cff5800a38dccce07712ba6e2 (diff)
gnu: xkbset: Update source URL and home page.
Source is unchanged compared to the previously-used tarball. * gnu/packages/xdisorg.scm (xkbset)[source]: Switch to 'git-fetch'. [home-page]: Switch to github.io.
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 9cc7cc652a..7965f432ed 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3172,11 +3172,13 @@ if there's more than one.")
(version "0.6")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://faculty.missouri.edu/~stephen/software/"
- name "/" name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stephenmontgomerysmith/xkbset")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "199mlm127zk1lr8nrq22n68l2l8cjwc4cgwd67rg1i6497n2y0xc"))))
+ (base32 "1b8jf5zfg4a82k7929jkb0prx8yy79nsxa0n7zhhk5a0hwpc32xx"))))
(build-system gnu-build-system)
(inputs
(list libx11 perl perl-tk))
@@ -3209,7 +3211,7 @@ if there's more than one.")
(string-append (assoc-ref outputs "out")
"/share/doc/" ,name "-" ,version))
#t)))))
- (home-page "https://faculty.missouri.edu/~stephen/software/")
+ (home-page "https://stephenmontgomerysmith.github.io/software/#xkbset")
(synopsis "User-preference utility for XKB extensions for X")
(description
"This is a program to help manage many of the XKB features of the X Window