summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-01-15 01:00:09 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-01-15 01:00:01 +0100
commitb35c1e5415dc8ef2547e9aa9a5bd63450c05118d (patch)
tree4f6be2bbda5e3acac0d9a1b174b0925167ac60cc /gnu/packages/xdisorg.scm
parent0e4afd4c8696fbafc3d24671a54b420aa5aa269f (diff)
gnu: arandr: Truth is obsolete.
* gnu/packages/xdisorg.scm (arandr)[source, arguments]: Remove trailing #t.
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 260839a6f6..f815462714 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -226,8 +226,7 @@ command line, without displaying a keyboard at all.")
;; pages (this is equivalent to 'gzip --no-name'.)
(substitute* "setup.py"
(("gzip\\.open\\(gzfile, 'w', 9\\)")
- "gzip.GzipFile('', 'wb', 9, open(gzfile, 'wb'), 0.)"))
- #t))))
+ "gzip.GzipFile('', 'wb', 9, open(gzfile, 'wb'), 0.)"))))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -236,15 +235,13 @@ command line, without displaying a keyboard at all.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "screenlayout/xrandr.py"
(("\"xrandr\"") (string-append "\"" (assoc-ref inputs "xrandr")
- "/bin/xrandr\"")))
- #t))
+ "/bin/xrandr\"")))))
(add-after 'install 'wrap-gi-typelib
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH")))
(wrap-program (string-append out "/bin/arandr")
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
- #t)))
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))))))
#:tests? #f)) ;no tests
(inputs `(("gtk+" ,gtk+)
("pycairo" ,python-pycairo)