summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-08-31 15:37:18 +0100
committerLeo Famulari <leo@famulari.name>2016-08-31 15:12:25 -0400
commit4493a3c2eff0f9206d04b6375658deb6f84dac5c (patch)
tree4e8ac2ac48c562111be78ee67aa1260974fd2b0b /gnu/packages/xdisorg.scm
parenta7074f47ad90efc4a0a4b67e64256d3641b59186 (diff)
gnu: Add xcb-util-xrm.
* gnu/packages/xdisorg.scm (xcb-util-xrm): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index cc83a04679..06ed052cf4 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
+;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -49,6 +50,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages m4)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
@@ -1021,3 +1023,42 @@ The taskbar includes transparency and color settings for the font, icons,
border, and background. It also supports multihead setups, customized mouse
actions, a built-in clock, a battery monitor and a system tray.")
(license license:gpl2)))
+
+(define-public xcb-util-xrm
+ (package
+ (name "xcb-util-xrm")
+ (version "1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Airblader/xcb-util-xrm/releases"
+ "/download/v" version "/xcb-util-xrm-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1h5vxwpd37dqfw9yj1l4zd9c5dj30r3g0szgysr6kd7xrqgaq04l"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Drop bundled m4.
+ '(delete-file-recursively "m4"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("m4" ,m4)
+ ("libx11" ,libx11))) ; for tests
+ (inputs
+ `(("libxcb" ,libxcb)
+ ("xcb-util" ,xcb-util)))
+ (home-page "https://github.com/Airblader/xcb-util-xrm")
+ (synopsis "XCB utility functions for the X resource manager")
+ (description
+ "The XCB util module provides a number of libraries which sit on
+top of libxcb, the core X protocol library, and some of the extension
+libraries. These experimental libraries provide convenience functions
+and interfaces which make the raw X protocol more usable. Some of the
+libraries also provide client-side code which is not strictly part of
+the X protocol but which has traditionally been provided by Xlib.
+
+XCB util-xrm module provides the following libraries:
+
+- xrm: utility functions for the X resource manager.")
+ (license license:x11)))