summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-04-18 22:42:24 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-18 22:57:52 +0200
commitab42a2a7272d7925c30a69e770f0e3281c1a7a2b (patch)
treebe8b2fbc026d8f12ed39a6ff73bd6c977afadc54 /gnu/packages/xdisorg.scm
parentf1f7049ec1f4b94fcf83ba68dcaab011280e7cb9 (diff)
gnu: Add xf86-input-wacom.
* gnu/packages/xdisorg.scm (xf86-input-wacom): New variable.
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 9e240db6c5..f928aa1f58 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -560,3 +560,39 @@ is already being used by the gnome-settings-daemon and the GNOME 3.4 Control
Center Wacom tablet applet. In the future, the xf86-input-wacom driver may
use it as well.")
(license license:x11)))
+
+(define-public xf86-input-wacom
+ (package
+ (name "xf86-input-wacom")
+ (version "0.29.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/linuxwacom/xf86-input-wacom/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "15lbzjkaf690i69qy0n0ibwczbclqq1nx0418c6a567by5v7wl48"))))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-sdkdir="
+ (assoc-ref %outputs "out")
+ "/include/xorg")
+ (string-append "--with-xorg-conf-dir="
+ (assoc-ref %outputs "out")
+ "/share/X11/xorg.conf.d"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("xorg-server" ,xorg-server)
+ ("libxrandr" ,libxrandr)
+ ("libxinerama" ,libxinerama)
+ ("libxi" ,libxi)
+ ("eudev" ,eudev)))
+ (home-page "http://linuxwacom.sourceforge.net/")
+ (synopsis "Wacom input driver for X")
+ (description
+ "The xf86-input-wacom driver is the wacom-specific X11 input driver for
+the X.Org X Server version 1.7 and later (X11R7.5 or later).")
+ (license license:x11)))