summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-17 20:47:11 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-17 20:47:11 +0200
commitd02bb02f7d833ad371c53c346b6cb77f01377cf4 (patch)
tree9506f04a7fde2f3b264ba1d2a9012085e1f72b72 /gnu/packages/xdisorg.scm
parentfb3ff265cd8c6b4c6160f94240dc8932097e637b (diff)
parentacce0a474c1493ab18912bc46285248e4ccb0314 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d886d3e69b..5f30df5efa 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1497,3 +1497,27 @@ before the system goes to sleep.")
"Pyperclip is a clipboard module for Python, handling copy/pasting from
the X11 clipboard")
(license license:bsd-3)))
+
+(define-public numlockx
+ (package
+ (name "numlockx")
+ (version "1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; It seems that upstream is gone.
+ (url "https://github.com/rg3/numlockx")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1w49fayhwzn5rx0z1q2lrvm7z8jrd34lgb89p853a024bixc3cf2"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("xorg-server" ,xorg-server)))
+ (home-page "https://github.com/rg3/numlockx")
+ (synopsis "Turns on the numlock key in X11")
+ (description "@command{numlockx} is a tiny program that lets you turn on
+the numlock key in X11. It can be called from the user's initialization files
+to automatically turn it on on login.")
+ (license license:expat)))