summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2022-03-21 19:31:43 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-01-29 09:17:00 +0800
commit956463a4c442d08721a60f3b39cbd04b6c6588ea (patch)
tree4b36481856846e333805c9b81d21b786104584d7 /gnu/packages/xfce.scm
parentd824836e860847ade7de47b179085c9a64bc4abe (diff)
gnu: Add thunar-media-tags-plugin.
* gnu/packages/xfce.scm (thunar-media-tags-plugin): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 43dbbfdf43..efd8656b8d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -54,6 +54,7 @@
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages linux)
#:use-module (gnu packages mate)
+ #:use-module (gnu packages mp3)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pdf)
#:use-module (gnu packages photo)
@@ -824,6 +825,28 @@ archive files using the file context menus in the Thunar file manager.")
Samba from Thunar (the Xfce file manager) without requiring root access.")
(license gpl2+)))
+(define-public thunar-media-tags-plugin
+ (package
+ (name "thunar-media-tags-plugin")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.xfce.org/src/thunar-plugins/"
+ name "/" (version-major+minor version)
+ "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32 "06sr7b4p9f585gian8vpx7j0pkzg0vvwcrjmrhvh7i5sb90w8rg2"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config intltool))
+ (inputs (list exo gtk+ thunar taglib))
+ (home-page "https://www.xfce.org/")
+ (synopsis "Media tags plugin for Thunar file manager")
+ (description
+ "Media tags plugin allows tags editing from Thunar file manager and
+tags-based file renaming from inside Thunar Bulk Renamer.")
+ (license gpl2+)))
+
(define-public xfwm4
(package
(name "xfwm4")