summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-13 20:53:59 -0500
committerMark H Weaver <mhw@netris.org>2014-12-14 19:46:12 -0500
commitbfb84869292c2699c3955c1cd7ac375c894a420a (patch)
tree6482a2515a501c499abb9a9255de0febaceb5d75 /gnu/packages/xfce.scm
parentd814f921f1d6ce2b318e4d458c9c5f8e8b9faa28 (diff)
gnu: Add xfce4-battery-plugin.
* gnu/packages/xfce.scm (xfce4-battery-plugin): New variable.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index d125a3367c..b2954ff083 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -276,6 +276,35 @@ applications menu, workspace switcher and more.")
;; Libraries are under LGPLv2.1+, and programs under GPLv2+.
(license (list gpl2+ lgpl2.1+))))
+(define-public xfce4-battery-plugin
+ (package
+ (name "xfce4-battery-plugin")
+ (version "1.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ name "/" (version-major+minor version) "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "04gbplcj8z4vg5xbks8cc2jjf62mmf9sdymg90scjwmb82pv2ngn"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs `(("glib" ,glib)
+ ("gtk+" ,gtk+-2)
+ ("libxfce4util" ,libxfce4util)
+ ("libxfce4ui" ,libxfce4ui)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin")
+ (synopsis "Battery monitor panel plugin for Xfce4")
+ (description
+ "A battery monitor panel plugin for Xfce4, compatible with APM and ACPI.")
+ ;; The main plugin code is covered by gpl2+, but the files containing code
+ ;; to read the battery state via ACPI or APM are covered by lgpl2.0+.
+ (license (list gpl2+ lgpl2.0+))))
+
(define-public xfce4-appfinder
(package
(name "xfce4-appfinder")