summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorFlorian Paul Schmidt <mista.tapas@gmx.net>2015-12-03 14:57:10 +0100
committerLeo Famulari <leo@famulari.name>2016-03-15 11:57:40 -0400
commitc29e5fda3ec65658597beaa1a2138e5aec8d9547 (patch)
tree103d6d2aa324d502ed9f28d01dc2b5b3a330da56 /gnu/packages/xfce.scm
parent75b314a615e7f1a62483046eb1d569ed88fd8530 (diff)
gnu: Add xfce4-power-manager.
* gnu/packages/xfce.scm (xfce4-power-manager): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index b62739622d..c1a432842c 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Florian Paul Schmidt <mista.tapas@gmx.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -721,3 +722,37 @@ on your desktop.")
"Xfce is a lightweight desktop environment. It aims to be fast and low on
system resources, while still being visually appealing and user friendly.")
(license gpl2+)))
+
+(define-public xfce4-power-manager
+ (package
+ (name "xfce4-power-manager")
+ (version "1.4.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/xfce/4.12"
+ "/src/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "04909sfc2nrj2wg9cw6y9y2r9yrp3l3vc201sy1gaiap67fi33h1"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--enable-gtk3")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("lbxrandr" ,libxrandr)
+ ("upower" ,upower)
+ ("libnotify" ,libnotify)
+ ("libxfce4ui" ,libxfce4ui)))
+ (home-page "http://www.xfce.org/")
+ (synopsis "Xfce Power Manager")
+ (description
+ "This is a power manager for the Xfce desktop. It manages the power
+sources on the computer and the devices that can be controlled to reduce their
+power consumption (such as LCD brightness level, monitor sleep, CPU frequency
+scaling, etc). In addition, xfce4-power-manager provides a set of
+freedesktop-compliant DBus interfaces to inform other applications about current
+power level so that they can adjust their power consumption, and it provides the
+inhibit interface which allows applications to prevent automatic sleep.")
+ (license gpl2+)))