summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 23:50:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:36 +0100
commite85de10877f21f82500ed79c5045de5c2e52a206 (patch)
treec98bd3ddb20b76e3100d39036100aa0bca04ac28 /gnu/packages/xml.scm
parent5c1cf7f30a11667c50e1c6b82205bc8ad2c0d66f (diff)
gnu: Add ghc-hxt-unicode.
* gnu/packages/xml.scm (ghc-hxt-unicode): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 0639adcda9..c538021cb0 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2030,3 +2030,31 @@ blocks and char properties and character predicates defined by XML. The
supported Unicode version is 7.0.0")
(license license:expat)))
+(define-public ghc-hxt-unicode
+ (package
+ (name "ghc-hxt-unicode")
+ (version "9.0.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/hxt-unicode/hxt-unicode-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0rj48cy8z4fl3zpg5bpa458kqr83adav6jnqv4i71dclpprj6n3v"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-hxt-charproperties" ,ghc-hxt-charproperties)))
+ (home-page
+ "http://www.fh-wedel.de/~si/HXmlToolbox/index.html https://github.com/UweSchmidt/hxt")
+ (synopsis
+ "Unicode en-/decoding functions for utf8, iso-latin-* and other encodings")
+ (description
+ "This package provides Unicode encoding and decoding functions for
+encodings used in the Haskell XML Toolbox. ISO Latin 1-16, utf8, utf16, ASCII
+are supported. Decoding is done with lazy functions, errors may be detected or
+ignored.")
+ (license license:expat)))
+