summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-08-31 23:41:38 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-31 23:43:55 +0200
commit1b3f5fc3878e3fc7852de6afd5032c1e43435d5e (patch)
treebf34f63dc74182d4e968264f7c26dfd320fb67b0 /gnu/packages/xml.scm
parent0ff44ba4642c4ae672a7c66108a46f8d311955c2 (diff)
gnu: libxml2/fixed: Use patches from inherited package.
This is a followup to 76fed2b3c4e3703d1ad81c4330edd94d551b6334. * gnu/packages/xml.scm (libxml2/fixed)(patches): Inherit patches from LIBXML2.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index b4aa89e881..96553c97b2 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -147,11 +147,12 @@ project (but it is usable outside of the Gnome platform).")
(origin
(inherit (package-source libxml2))
(patches
+ (append (origin-patches (package-source libxml2))
(search-patches "libxml2-CVE-2017-0663.patch"
"libxml2-CVE-2017-7375.patch"
"libxml2-CVE-2017-7376.patch"
"libxml2-CVE-2017-9047+CVE-2017-9048.patch"
- "libxml2-CVE-2017-9049+CVE-2017-9050.patch"))))))
+ "libxml2-CVE-2017-9049+CVE-2017-9050.patch")))))))
(define-public python-libxml2
(package (inherit libxml2)