summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-27 23:54:23 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-27 23:54:23 +0100
commit2a8d44015ff2672b7a9a2ea5054b51a83b0e934b (patch)
tree00cdf5dac6acd2bd736a726bc5e032f328d29d6a /gnu/packages/xml.scm
parentcc9a5c1454f49850c078045c88a300c1195eabc8 (diff)
gnu: libxml2: Add search path specification.
* gnu/packages/xml.scm (libxml2)[native-search-paths, search-paths]: New fields. * gnu/packages/gnome.scm (gnome-doc-utils)[arguments]: Remove. * gnu/packages/gps.scm (gpscorrelate)[arguments]: Remove settings for 'XML_CATALOG_FILES' from 'configure' phase. * gnu/packages/web.scm (tinyproxy)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 63d0ef2132..62f8c3c376 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -68,6 +68,18 @@ things the parser might find in the XML document (like start tags).")
(inputs `(("zlib" ,zlib)))
(native-inputs `(("perl" ,perl)
("python" ,python-2))) ; incompatible with Python 3 (print syntax)
+
+
+ ;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
+ ;; sub-directory of any given package.
+ (native-search-paths (search-path-specification
+ (variable "XML_CATALOG_FILES")
+ (separator " ")
+ (files '("xml"))
+ (file-pattern "^catalog\\.xml$")
+ (file-type 'regular)))
+ (search-paths native-search-paths)
+
(arguments
`(#:phases
(alist-replace