summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-02-10 17:34:43 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-02-10 19:04:02 +0100
commit9a86ee788d8941dcd017ac40d5f785c08225f89f (patch)
tree3ee6e01f5d0c37a2f5c95b1001aef0d4f30e6d3b /gnu/packages/xml.scm
parent1a17ca2624dd6dbbdaaecd4754ed41327351437e (diff)
gnu: Add java-apache-xml-commons-resolver.
* gnu/packages/xml.scm (java-apache-xml-commons-resolver): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 0a16d7d812..741ab2853c 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1542,3 +1542,42 @@ the Xerces-J XML parser and Xalan-J XSLT processor and specifies these APIs:
(license (list license:asl2.0
license:w3c ;; Files under org.w3c
license:public-domain)))) ;; org.xml.sax
+
+(define-public java-apache-xml-commons-resolver
+ (package
+ (name "java-apache-xml-commons-resolver")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://apache/xerces/xml-commons/"
+ "xml-commons-resolver-" version ".tar.gz"))
+ (sha256
+ (base32 "1zhy4anc3fg9f8y348bj88vmab15aavrg6nf419ifb25asyygnsm"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (for-each delete-file (find-files "." ".*\\.(jar|zip)"))
+ #t))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name (string-append "xml-resolver.jar")
+ #:tests? #f)); no tests
+ (inputs
+ `(("java-junit" ,java-junit)))
+ (home-page "http://xerces.apache.org/xml-commons/")
+ (synopsis "Catalog-based entity and URI resolution")
+ (description "The resolver class implements the full semantics of OASIS Technical
+Resolution 9401:1997 (Amendment 2 to TR 9401) catalogs and the 06 Aug
+2001 Committee Specification of OASIS XML Catalogs.
+
+It also includes a framework of classes designed to read catalog files
+in a number of formats:
+
+@itemize
+@item The plain-text flavor described by TR9401.
+@item The XCatalog XML format defined by John Cowan
+@item The XML Catalog format defined by the OASIS Entity Resolution
+ Technical Committee.
+@end itemize")
+ (license license:asl2.0)))