summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-11-08 17:12:01 -0500
committerLeo Famulari <leo@famulari.name>2016-11-09 10:19:49 -0500
commit0b34b58688ac0d9bc0e2700acf82269e67ccdfa3 (patch)
tree2c67f3795ec59c682cd96778ff5a16e5f80a1a36 /gnu/packages/xml.scm
parentd887f420d2a83616a22671968b5a7d1700b58aec (diff)
gnu: libxslt: Fix CVE-2016-4738.
* gnu/packages/patches/libxslt-CVE-2016-4738.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/xml.scm (libxslt)[replacement]: New field. (libxslt/fixed): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 879b37a337..d6c034bc26 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -147,6 +147,7 @@ project (but it is usable outside of the Gnome platform).")
(define-public libxslt
(package
(name "libxslt")
+ (replacement libxslt/fixed)
(version "1.1.29")
(source (origin
(method url-fetch)
@@ -168,6 +169,14 @@ project (but it is usable outside of the Gnome platform).")
based on libxml for XML parsing, tree manipulation and XPath support.")
(license license:x11)))
+(define libxslt/fixed
+ (package
+ (inherit libxslt)
+ (name "libxslt")
+ (source (origin
+ (inherit (package-source libxslt))
+ (patches (search-patches "libxslt-CVE-2016-4738.patch"))))))
+
(define-public perl-graph-readwrite
(package
(name "perl-graph-readwrite")