summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-14 14:37:34 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-09-05 21:30:56 +0300
commit0c1bab36a99b7e5658a775d49df30a78a6295c46 (patch)
tree1e4aff2e796a09f51e01063d59a30b01bb9263b5 /gnu/packages/xml.scm
parent428e4463c3352ede41e8ccbe69b681054a4f90fa (diff)
gnu: Add perl-xml-xpath.
* gnu/packages/xml.scm (perl-xml-xpath): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index a478599fe6..52578693fa 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -563,6 +564,30 @@ encoding of the message to be send into XML, sending the message to the
server, collect the answer, and finally decoding the XML to Perl.")
(license (package-license perl))))
+(define-public perl-xml-xpath
+ (package
+ (name "perl-xml-xpath")
+ (version "1.37")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MA/MANWAR/"
+ "XML-XPath-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0997l8vjgq8p7d1irvp6amqyrv24x7f8hybjm4l4ayag32b13bmq"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-path-tiny" ,perl-path-tiny)))
+ (inputs
+ `(("perl-xml-parser" ,perl-xml-parser)))
+ (home-page "http://search.cpan.org/dist/XML-XPath")
+ (synopsis "Parse and evaluate XPath statements")
+ (description
+ "This module aims to comply exactly to the @url{XPath specification,
+https://www.w3.org/TR/xpath} and yet allow extensions to be added in
+the form of functions.")
+ (license (package-license perl))))
+
(define-public pugixml
(package
(name "pugixml")