summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-05-18 13:26:17 -0400
committerLeo Famulari <leo@famulari.name>2016-05-19 10:27:18 -0400
commit119b83989dd9edd1e8ba6cd379d159d024cbc61d (patch)
treeb94f92b990229fc5cebde7735f1545f22270c936 /gnu/packages/xml.scm
parent9684e30b9b597b93ae9c797ba8f3b40eff893ebe (diff)
gnu: expat: Fix CVE-2016-0718. Improve fix for CVE-2015-1283.
* gnu/packages/patches/expat-CVE-2015-1283-refix.patch, gnu/packages/patches/expat-CVE-2016-0718.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/xml.scm (expat)[replacement]: New field. (expat/fixed): New variable. [source]: Use new patches.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index e1f111e329..9eaf71aefa 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Raimon Grau <raimonster@gmail.com>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -44,6 +45,7 @@
(define-public expat
(package
(name "expat")
+ (replacement expat/fixed)
(version "2.1.0")
(source (origin
(method url-fetch)
@@ -62,6 +64,15 @@ stream-oriented parser in which an application registers handlers for
things the parser might find in the XML document (like start tags).")
(license license:expat)))
+(define expat/fixed
+ (package
+ (inherit expat)
+ (source (origin
+ (inherit (package-source expat))
+ (patches (search-patches "expat-CVE-2015-1283.patch"
+ "expat-CVE-2015-1283-refix.patch"
+ "expat-CVE-2016-0718.patch"))))))
+
(define-public libxml2
(package
(name "libxml2")