summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-06-19 13:56:53 -0400
committerMark H Weaver <mhw@netris.org>2016-06-19 13:59:01 -0400
commit3ebba94d45e4cc9c5242f812b29c826904506b02 (patch)
treee5bc639927fe83653df42671de5accb01b13d99f /gnu/packages/xml.scm
parentcb1436d8d24fba75dccd8b9574479acc35d8a1b3 (diff)
gnu: libxslt: Replace with 1.1.29 [fixes CVE-2016-{1683,1684}].
* gnu/packages/xml.scm (libxslt)[replacement]: New field. (libxslt/fixed): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 81a71bde6c..812539f397 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Raimon Grau <raimonster@gmail.com>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
@@ -154,6 +154,7 @@ project (but it is usable outside of the Gnome platform).")
(package
(name "libxslt")
(version "1.1.28")
+ (replacement libxslt/fixed) ; CVE-2016-1683 and CVE-2016-1684
(source (origin
(method url-fetch)
(uri (string-append "ftp://xmlsoft.org/libxslt/libxslt-"
@@ -174,6 +175,19 @@ project (but it is usable outside of the Gnome platform).")
based on libxml for XML parsing, tree manipulation and XPath support.")
(license license:x11)))
+(define-public libxslt/fixed
+ (package
+ (inherit libxslt)
+ (source
+ (let ((version "1.1.29"))
+ (origin
+ (method url-fetch)
+ (uri (string-append "ftp://xmlsoft.org/libxslt/libxslt-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1klh81xbm9ppzgqk339097i39b7fnpmlj8lzn8bpczl3aww6x5xm")))))))
+
(define-public perl-xml-parser
(package
(name "perl-xml-parser")