summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-14 14:50:00 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-09-05 21:31:07 +0300
commitb2696a58b3c601abf02ff40cd915c4f6b195743b (patch)
tree1fddb03cd508fe8728e40aa7b4f65199d2947084 /gnu/packages/xml.scm
parent0c1bab36a99b7e5658a775d49df30a78a6295c46 (diff)
gnu: Add perl-xml-atom.
* gnu/packages/xml.scm (perl-xml-atom): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 52578693fa..f2fa725b87 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -186,6 +186,38 @@ which read a graph file and create an instance of the Graph class.
the @code{Graph} class and write it out in a specific file format.")
(license (package-license perl))))
+(define-public perl-xml-atom
+ (package
+ (name "perl-xml-atom")
+ (version "0.41")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MI/MIYAGAWA/"
+ "XML-Atom-" version ".tar.gz"))
+ (sha256
+ (base32
+ "17lnkb9ymrhk2z642bhj5i2bv3q1da3kpp2lvsl0yhqshk3wdjj8"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-datetime" ,perl-datetime)
+ ;; TODO package: perl-datetime-format-atom
+ ("perl-xml-xpath" ,perl-xml-xpath)))
+ (inputs
+ `(("perl-class-data-inheritable" ,perl-class-data-inheritable)
+ ("perl-datetime" ,perl-datetime)
+ ("perl-datetime-timezone" ,perl-datetime-timezone)
+ ("perl-digest-sha1" ,perl-digest-sha1)
+ ("perl-libwww" ,perl-libwww)
+ ("perl-uri" ,perl-uri)
+ ("perl-xml-libxml" ,perl-xml-libxml)
+ ("perl-xml-xpath" ,perl-xml-xpath)))
+ (home-page "http://search.cpan.org/dist/XML-Atom")
+ (synopsis "Atom feed and API implementation")
+ (description
+ "Atom is a syndication, API, and archiving format for weblogs and other data.
+@code{XML::Atom} implements the feed format as well as a client for the API.")
+ (license (package-license perl))))
+
(define-public perl-xml-parser
(package
(name "perl-xml-parser")