summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-09 21:16:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-02 18:39:15 +0100
commit62b28f192b87797ca3d0c7c7c90bd29bb55ae4a3 (patch)
tree3e78fab892e7b7a9c847da7b1e619ff7186f4165 /gnu/packages/xml.scm
parent456f14f0fec907391e1a729107cec894c52bdda6 (diff)
gnu: Add perl-xml-tokeparser.
* gnu/packages/xml.scm (perl-xml-parser): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index b91471690f..f66b8a65b7 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -269,6 +269,29 @@ as extra arguments to the parse methods, in which case they override options
given at XML::Parser creation time.")
(home-page "http://search.cpan.org/dist/XML-Parser")))
+(define-public perl-xml-tokeparser
+ (package
+ (name "perl-xml-tokeparser")
+ (version "0.05")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/P/PO/PODMASTER/"
+ "XML-TokeParser-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hnpwb3lh6cbgwvjjgqzcp6jm4mp612qn6ili38adc9nhkwv8fc5"))))
+ (build-system perl-build-system)
+ (propagated-inputs `(("perl-xml-parser" ,perl-xml-parser)))
+ (home-page "http://search.cpan.org/dist/XML-TokeParser")
+ (synopsis "Simplified interface to XML::Parser")
+ (description
+ "@code{XML::TokeParser} provides a procedural (\"pull mode\") interface
+to @code{XML::Parser} in much the same way that Gisle Aas'
+@code{HTML::TokeParser} provides a procedural interface to @code{HTML::Parser}.
+@code{XML::TokeParser} splits its XML input up into \"tokens\", each
+corresponding to an @code{XML::Parser} event.")
+ (license (package-license perl))))
+
(define-public perl-libxml
(package
(name "perl-libxml")