summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-03-02 10:37:28 +0000
committerChristopher Baines <mail@cbaines.net>2023-03-02 10:55:08 +0000
commit7df09ee0ab3e7962ef27859ce87e06a323059284 (patch)
treed81334f742ddcb9a1ee63961ca6410922980af1c /gnu/packages/xml.scm
parent2ac51ec99b58b50c08ba719a8c7e9dba0330b065 (diff)
parentaf95f2d8f98eb2c8c64954bb2fd0b70838899174 (diff)
Merge remote-tracking branch 'savannah/master' into core-updates
Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index fc3c1839b2..e0de8d52cf 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -435,7 +435,7 @@ based on libxml for XML parsing, tree manipulation and XPath support.")
(list opensp))
(native-inputs
(list perl))
- (home-page "http://openjade.sourceforge.net/")
+ (home-page "https://openjade.sourceforge.net/")
(synopsis "ISO/IEC 10179:1996 standard DSSSL language implementation")
(description "OpenJade is an implementation of Document Style Semantics
and Specification Language (DSSSL), a style language to format SGML or XML
@@ -1088,7 +1088,7 @@ parsing/saving.")
(base32
"1d17pyixbfvjyi2lb0cfp0ch8wwdf44mmg3r5pwqhyyqs66z601a"))))
(build-system python-build-system)
- (home-page "http://pyxb.sourceforge.net/")
+ (home-page "https://pyxb.sourceforge.net/")
(synopsis "Python XML Schema Bindings")
(description
"PyXB (\"pixbee\") is a pure Python package that generates Python source
@@ -1137,14 +1137,14 @@ XSL-T processor. It also performs any necessary post-processing.")
(define-public xmlsec
(package
(name "xmlsec")
- (version "1.2.36")
+ (version "1.2.37")
(source (origin
(method url-fetch)
(uri (string-append "https://www.aleksey.com/xmlsec/download/"
"xmlsec1-" version ".tar.gz"))
(sha256
(base32
- "100wsklff8x30rsg0xp191kg8p3z5va2d0q3iy08a791ic07xngh"))))
+ "0747w8mnnyawvvzlvhjpkwm3998c7l5f1hjy1gfvsmhydp5zp3az"))))
(build-system gnu-build-system)
(propagated-inputs ; according to xmlsec1.pc
(list libxml2 libxslt))
@@ -1334,7 +1334,7 @@ C++ programming language.")
#t))))))
(inputs
(list libxslt libxml2))
- (home-page "http://xmlstar.sourceforge.net/")
+ (home-page "https://xmlstar.sourceforge.net/")
(synopsis "Command line XML toolkit")
(description "XMLStarlet is a set of command line utilities which can be
used to transform, query, validate, and edit XML documents. XPath is used to
@@ -1710,7 +1710,7 @@ support.")
(substitute* "GNUmakefile"
(("#! /bin/sh") (which "sh")))
#t)))))
- (home-page "http://xmlrpc-c.sourceforge.net/")
+ (home-page "https://xmlrpc-c.sourceforge.net/")
(synopsis "Lightweight RPC library based on XML and HTTP")
(description
"XML-RPC is a quick-and-easy way to make procedure calls over the Internet.
@@ -1795,7 +1795,7 @@ modular implementation of XML-RPC for C and C++.")
(files '("sgml"))
(file-pattern "^catalog$|^CATALOG$|^.*\\.cat$")
(file-type 'regular))))
- (home-page "http://openjade.sourceforge.net/")
+ (home-page "https://openjade.sourceforge.net/")
(synopsis "Suite of SGML/XML processing tools")
(description "OpenSP is an object-oriented toolkit for SGML parsing and
entity management. It is a fork of James Clark's SP suite. The tools it