summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-01-07 21:17:02 +0100
committerLudovic Courtès <ludo@gnu.org>2024-01-07 21:29:53 +0100
commitb71d2ba8785e9883f4f2d239c557c9034b6be876 (patch)
tree52858686958c4c66c6c1f7a98ae63c3269eacb15 /gnu/packages/xorg.scm
parentc5d670308cbd0a6ee67e04e58cb77fa40e8ad328 (diff)
parent5f8a993aa85554ca09bd27139230d7664107e1b6 (diff)
Merge branch 'master' into core-updates
Change-Id: I150b4077fffca97c860439292a8d053579d64cb7
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm32
1 files changed, 27 insertions, 5 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 38261fda3c..0ec4dd8c7d 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1498,7 +1498,11 @@ treat it as part of their software base when porting.")
"1zi0r6mqa1g0hhsp02cdsjcxmsbipiv0v65c1h4pl84fydcjikbm"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")))
+ `(#:configure-flags '("--disable-static"
+ ;; This fixes cross compiling.
+ ,@(if (%current-target-system)
+ '("--enable-malloc0returnsnull=yes")
+ '()))))
(propagated-inputs
(list libx11 libxext xorgproto))
(native-inputs
@@ -5013,7 +5017,7 @@ by the Xorg server.")
(define-public xorg-server
(package
(name "xorg-server")
- (version "21.1.9")
+ (version "21.1.10")
(source
(origin
(method url-fetch)
@@ -5021,7 +5025,7 @@ by the Xorg server.")
"/xserver/xorg-server-" version ".tar.xz"))
(sha256
(base32
- "0fjk9ggcrn96blq0bm80739yj23s3gjjjsc0nxk4jk0v07i7nsgz"))
+ "1l0iaq83vbl9jr34sa7v7630c5bnp64drlw8yg6c6yn5xyib7c6f"))
(patches
(list
;; See:
@@ -5673,11 +5677,29 @@ The XCB util-keysyms module provides the following library:
"0nza1csdvvxbmk8vgv8vpmq7q8h05xrw3cfx9lwxd1hjzd47xsf6"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")))
+ `(#:configure-flags '("--disable-static")
+ ,@(if (and (%current-target-system)
+ (target-riscv64?))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'update-config-scripts
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.guess and config.sub.
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub"))))))
+ '())))
(propagated-inputs
(list libxcb))
(native-inputs
- (list pkg-config))
+ (append (if (and (%current-target-system)
+ (target-riscv64?))
+ (list config)
+ '())
+ (list pkg-config)))
(home-page "https://cgit.freedesktop.org/xcb/util-renderutil/")
(synopsis "Convenience functions for the Render extension")
(description