summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-02 08:07:11 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-02 08:07:11 +0100
commit3d4fc910f73220f47e5f2459853333a7c83c5d1d (patch)
treed3178f93b78b3629dc7067cef69cf2a95490966d /gnu/packages/xorg.scm
parent9160cccd767cdfa55f7a460750c6b0f7544c12eb (diff)
parent4a0549be52f3f46fbce61342d8de30f7b83130c5 (diff)
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm27
1 files changed, 25 insertions, 2 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index c003754930..073573dc0b 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5217,10 +5217,33 @@ application-facing EGL functions.")
(home-page "https://github.com/NVIDIA/eglexternalplatform")
(license license:expat)))
+(define-public egl-gbm
+ (package
+ (name "egl-gbm")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/NVIDIA/egl-gbm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "125h1751vdg60klci0cbmcqj46spxalzqawvvd469qvx69bm30da"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list eglexternalplatform mesa))
+ (synopsis "GBM EGL external platform library")
+ (description
+ "This package provides an EGL External Platform library implementation for
+GBM EGL support.")
+ (home-page "https://github.com/NVIDIA/egl-gbm")
+ (license license:expat)))
+
(define-public egl-wayland
(package
(name "egl-wayland")
- (version "1.1.11")
+ (version "1.1.13")
(source
(origin
(method git-fetch)
@@ -5229,7 +5252,7 @@ application-facing EGL functions.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "11a3j2rjai2vsway9ki5y3ncvhrwd300pz2zcq36mq3brbr1vgf5"))))
+ (base32 "0irmvp8g2wn18q6k3vcmg4a57q4ddmqccv3g7hbysqnsdsps63rl"))))
(build-system meson-build-system)
(native-inputs
(cons* libglvnd ;needed for headers