summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-22 12:42:52 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-22 13:31:48 +0100
commitba5e23d605dbbae7541d8d9a680e8fde3ad1d745 (patch)
treebdbb0d812e88e836559b97f33791de18b7f1f3dc /gnu/packages/xorg.scm
parentc05be50a6f95ac57924c9d7b6330f63c7d4346b0 (diff)
gnu: xcb-proto: Update to 1.12.
* gnu/packages/patches/xcb-proto-python3-print.patch, gnu/packages/patches/xcb-proto-python3-whitespace.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/xorg.scm (xcb-proto): Update to 1.12. [source]: Use patches. Download from new home. [home-page]: Change to new xcb.fd.o home.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index dc500641f0..8bc54e6d52 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2053,21 +2053,24 @@ emulate a TI-30 or an HP-10C.")
(define-public xcb-proto
(package
(name "xcb-proto")
- (version "1.11")
+ (version "1.12")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://xorg/individual/xcb/xcb-proto-"
+ "https://xcb.freedesktop.org/dist/xcb-proto-"
version
".tar.bz2"))
(sha256
(base32
- "0bp3f53l9fy5x3mn1rkj1g81aiyzl90wacwvqdgy831aa3kfxb5l"))))
+ "01j91946q8f34l1mbvmmgvyc393sm28ym4lxlacpiav4qsjan8jr"))
+ (patches
+ (search-patches "xcb-proto-python3-whitespace.patch"
+ "xcb-proto-python3-print.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config) ("python" ,python-minimal-wrapper)))
- (home-page "https://www.x.org/wiki/")
+ (home-page "https://xcb.freedesktop.org/")
(synopsis "XML-XCB protocol descriptions")
(description
"XCB-Proto provides the XML-XCB protocol descriptions that libxcb