summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-08 00:40:37 -0500
committerLeo Famulari <leo@famulari.name>2017-03-08 03:52:03 -0500
commitda79e82b14b78dba7247cd39c370efd7887ed9fc (patch)
tree6882c612df5999f64a1513b14b036815d4ddbd5b /gnu/packages/xorg.scm
parent9a91b00fd08e652d158bd6bf96bdcb045f7c72cb (diff)
gnu: gtk+: Build GTK+ with its own xorg-server package.
This will allow us to update xorg-server directly on the master branch. * gnu/packages/xorg.scm (xorg-server-1.19.2): New variable. * gnu/packages/gtk.scm (gtk+) [native-inputs]: Use xorg-server-1.19.2 instead of xorg-server. [arguments]: Add xorg-server-1.19.2 to #:disallowed-references.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 5c9300e209..bd8f38c398 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5111,6 +5111,22 @@ communicates with the user via graphical controls such as buttons and
draggable titlebars and borders.")
(license license:x11)))
+;;; This package is intended to be used when building GTK+.
+(define-public xorg-server-1.19.2
+ (package
+ (inherit xorg-server)
+ (name "xorg-server")
+ (version "1.19.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/individual/xserver/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1fw4b2lf75nsqkiyhn95b1c2if1l3cw5a188a1szx1d8l7sbk2jg"))))))
+
(define-public xorg-server-xwayland
(package
(inherit xorg-server)