summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 02:50:46 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:42:36 -0400
commit859e8873d08f43787f02d4ce4b2b8482a3cf0fa7 (patch)
tree0fa23e3d57f1d4650ed50e8c9377e9e8c365e03d /gnu/packages/xorg.scm
parent173b647fa5160485671a73112464bafe70adfe16 (diff)
gnu: imake: Use invoke.
* gnu/packages/xorg.scm (imake)[arguments]: Use invoke and remove vestigial plumbing from the 'install-data' phase.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index d8bfa9054a..c03e1427e9 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014, 2015, 2017 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
@@ -137,10 +137,10 @@
(substitute* '("mingw.cf" "Imake.tmpl" "nto.cf" "os2.cf"
"linux.cf" "Amoeba.cf" "cygwin.cf")
(("/bin/sh") (which "bash")))
- (and (zero? (system* "./configure"
- (string-append "SHELL=" (which "bash"))
- (string-append "--prefix=" out)))
- (zero? (system* "make" "install"))))))))))
+ (invoke "./configure"
+ (string-append "SHELL=" (which "bash"))
+ (string-append "--prefix=" out))
+ (invoke "make" "install"))))))))
(home-page "https://www.x.org/")
(synopsis "Source code configuration and build system")
(description